Browser Plug-Ins used on DRpure.com

DRpure.com makes extensive use of two plug-ins. If you do not already have them installed, download them now and enjoy the many added features only visible with these plug-ins.

Marcomedia's Flash Plug In: Necessary
Needed is version 5 or above. Click the icon below to get the latest for your system. A new brwser window will open.


Apple's QuickTime: Greatly suggested
Needed is version 4 or above. Click the icon below to get the latest for your system. A new brwser window will open.